Getting there, but a little help needed! 8mm Very Scilly Scanner with DSuper8

repost as the original one went missing, will try and re-write as best I can!

Hello all, hoping everyone’s new year has gotton off to a good start!
My new years resolution is to have this very scilly scanner finished…fingers crossed.

Its such a huge learning curve for someone with no Pi or python experience but I am slowly getting there. I would say I’m probably in the ‘prototyping’ phase, right at the start, but making small leaps and bounds.

So what I want to do is test and play with the DSuper8 software taking photos and making sure I can get the right light and colours before moving forward with my design.
I am SO CLOSE! to getting it to take a picture, I can taste it! haha.
here is what I am stuck on.

I can connect to the RPi using a PC, but when I try to connect to the server I have set up on the Pi, I get this:


I have followed the instructions as best I can, and I’m fairly sure I’ve done everything right, but I think it may have something to do with this error message that the server is giving when I start it on the Pi

If anyone can be of any help I would really appreciate it. As I say right now I just want to be able to connect and take a few photos, play around with light sources before moving forward!

A big thank you to Manuel for making such a brilliant piece of software, I don’t think I’d be able to do anything without it!!

… that was quite fast! :smile:

(seem to be an issue with the camera initialization. There were recent changes (new “sensor” config vs. old “raw” config) which might need to be adapted in Manuel’s software. Can you post the version of picamera2 you have installed, maybe also the OS- and the libcamera-version you are using?)

Hi @Rowan,

My original post has disappeared. This is a second post.

First of all, thank you for your kind words.

I encourage you to continue developing your scanner.

From the messages that appear when the server starts up, it seems that you have an incorrect version of libcamera installed:
libcamera0.0.5/stable 0.0.5~83+bde9b04f-3 arm64
complex camera support library

This library is not installed on my server.

I assume you have the latest version of Raspberry Pi OS (Bookworm) installed.
Make sure you have both Bookworm and the picamera2 library updated:

Update Bookworm:
sudo apt update
sudo apt full-upgrade

Install picamera2:
sudo apt install python3-picamera2

Cleaning after software installation:
sudo apt clean

The response of the DSuper8 server after a successful boot is as follows:

If you have an RPi 4, you can run both the client and the server simultaneously on the same machine. I think it would make testing easier for you.

Best regards and good luck.

2 Likes

Thank you for the reply! :smiley:
I am currently battleing libcamera, no matter what I do it seems to be stuck at verison libcamera v0.0.5+83-bde9b04f
Very odd, will report back when I finally get it sorted.

Hmm. Ignore me. I seem to be running Bullseye…
clearly I need to update myself as well as this Pi. :confused:

Hi again @Rowan,

The DSuper8 server software ver. 20231130 only works with Bookworm.
Bookworm is very easy to install with the software Raspberry Pi Imager

However, I want to make some suggestions that will facilitate life.

Bookworm is configured by default to execute the Wayland graphic system. Although it is undoubtedly the future, in my opinion it is not yet fully mature for use generalized.
When I installed Bookworm I was testing it for a few days. Unfortunately I found so many inconveniences that, finally, I decided to return to the traditional X11 with the OpenBox window manager. As desktop graphic environment, LxQt works very well.

To use X11-OpenBox once the operating system is installed, run the raspi-config utility in an lxterminal window:

sudo raspi-config

main menu option 6 (Advanced options) → submenu option A6 (Wayland) → sub-submenu option W1 (Openbox window manager with X11 backend)

Restart RPi and you would already have the X11 graphics system operational.

To install LxQt:
sudo apt install lxqt-core lxqt oxygen-icon-theme
sudo apt clean

To select lxqt as the default boot option:
sudo update-alternatives --config x-session-manager

Logically, in the list that appears choose the option /usr/bin/startlxqt

Restart RPi and you would have the LxQt desktop environment operational.

To configure the desktop:
Right click on the desktop → desktop preferences

More settings:
In a lxterminal window:
lxqt-config-appearance

With these operations you would have a basic system in operation.

Good luck with Bookworm

4 Likes

I just wanted to say thank you for all your help - I’d been ill for a while there and wasn’t able to work on it but I had a crack at it today…and everything is working :smiley: Exciting times.

3 Likes

Hi @Rowan,

My most sincere congratulations.

I always find it exciting to see my software running on other users’ computers. I hope it meets your expectations.

Best regards